Canvas Issues related to AWS outage

Incident Report for University of Mary Washington

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:15 EDT

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 07:13 EDT

Update

Canvas is operational.
Posted Oct 21, 2025 - 07:13 EDT

Investigating

Canvas is experiencing degraded performance due to problems with Amazon Web Services that began overnight. While you may be able to log in, not all features may be working as expected. Updates on Canvas status are available on the Instructure Status Page.
Posted Oct 20, 2025 - 08:58 EDT
This incident affected: Teaching and Learning Systems - Canvas, Library, DoOO, Sites@UMW, Lab Printing (Canvas).