Outlook - Web Access

Incident Report for University of Mary Washington

Resolved

The issue with accessing email using Office 365 webmail has been resolved. If you are still experiencing any issues, please contact the Help Desk (540) 654-2255 or helpdesk@umw.edu.
Posted Jun 06, 2023 - 08:32 EDT

Investigating

Office 365 webmail is still experiencing connectivity issues. Microsoft is aware of this and working to fix this issue.
Posted Jun 05, 2023 - 16:27 EDT
This incident affected: Employee Systems - Email, SharePoint, Phone, Shared Network Drives (Employee Email - Exchange and Outlook Web Access).