Website issues
Incident Report for University of Mary Washington
Resolved
We have worked with our vendor to restore service to the UMW website. If you continue to experience issues, you may need to clear your browser history.
Posted 4 months ago. May 17, 2019 - 09:46 EDT
Investigating
Many UMW web pages are currently experiencing service interruptions. We are working with our hosting provider to resolve the issues as soon as possible. Updates will be posted on http://status.umw.edu/.
Posted 4 months ago. May 16, 2019 - 16:35 EDT
This incident affected: UMW Systems - Banner, MyTime, Website, EagleOne, UMW Wireless, Internet (UMW Website).