Banner is Down
Incident Report for University of Mary Washington
Resolved
Banner is back online. Thank you for your patience.
Posted Dec 03, 2019 - 10:19 EST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 10:16 EST
Investigating
Banner is currently down and technicians are working on getting it back online.
Posted Dec 03, 2019 - 09:05 EST