Outlook - Web Access
Incident Report for University of Mary Washington
Resolved
You should now be able to access Outlook using webmail. If you have any issues, please contact the Help Desk. Phone: (540) 654-2255 or Email: helpdesk@umw.edu.
Posted Jun 05, 2023 - 14:31 EDT
Investigating
You should now be able to access Outlook using webmail. If you have any issues, please contact the Help Desk. Phone: (540) 654-2255 or Email: helpdesk@umw.edu.
Posted Jun 05, 2023 - 02:30 EDT
This incident affected: Employee Systems - Email, SharePoint, Phone, Shared Network Drives (Employee Email - Exchange and Outlook Web Access).