Reported Issues: MyTime
Incident Report for University of Mary Washington
Resolved
MyTime has been restored, data has been verified, and it has been released for use.
Posted Feb 01, 2022 - 10:53 EST
Identified
The Help Desk has received reports from users of MyTime

The Payroll and Finance teams are working with the vendor to restore service. We will update this page as we receive more information.

Updates will be posted to our UMW System Status page http://status.umw.edu and our Twitter account https://twitter.com/umwIT

Thanks for your patience as we work to resolve this issue. Please contact the IT Help Desk if you have any questions or concerns.

Phone: 540-654-2255
In Person: HCC Room 112
Email: helpdesk@umw.edu
Website: technology.umw.edu/helpdesk
Posted Dec 15, 2021 - 10:35 EST
This incident affected: UMW Systems - Banner, MyTime, Website, EagleOne, UMW Wireless, Internet (MyTime).