UMW Website Running Slowly
Incident Report for University of Mary Washington
Resolved
The speed issues with the UMW website are resolved. If you are experiencing any continued problems, please contact the Help Desk.
Posted Nov 12, 2018 - 08:03 EST
Investigating
Parts of the UMW website are moving slowly due to an increased load on our servers. Staff is investigating the cause.
Posted Nov 09, 2018 - 16:07 EST
This incident affected: UMW Systems - Banner, MyTime, Website, EagleOne, UMW Wireless, Internet (UMW Website).